Abode Photoshop- making a CD Cover

DESIGN PROCESS

1. Create a folder called CD COVER within your IST folder.
2. Within the CD COVER folder, create a folder called IMAGES.
3. Inselecting images for your CD cover you should try, wherever possible, to avoid breeching
copyright . The following sites may be of help:
http://www.zoo-m.com/flickr-storm/
http://pics.techdlearning.com/
http://www.pdclipart.org/
http://www.clipartof.com/

Save all your downloaded images in the IMAGES folder.
4. Consider the colour scheme for your CD Cover

background colour

text colour

REMEMBER:

This should be an original piece of work and NOT a copy of an existing CD Cover.
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Make sure you have ESSENTIALS selected for your toolboxes = = =
Click File > New

and set your image Width and Height to 12 cm.
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Color Modle: rCMYK Color ;I | 8 bit

Name: @ Cover [ oK il
~ Preset: | Custom Bl — Reset |
Sieer | | save Preset... |
Width: | 12 [cm ~| Delete Preset,., |
Height: | 12
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Backaround Contents: | Transparent .
Image Size:

12.4M
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Resolution “

Resolution is a number of ﬁ'xels on a printed area of an image. The higher the resolution, the more

pixels there are on the pagey the better is the quality of the image. However, high resolution increas-

es the size of the file. The standard recommended resolution for printed images is 150-300, for Web
\
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images it is 72.
Color Mode

\
Choose a color mode that will begt fit your project. For example, when making a graphic for a web

site, choose RGB. When making ah image for print, choose CMYK.
\
You may wish to change the Background Contents

to Colour or Transparent. o
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Click File >Save e
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File name should be: o
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CD Cover )
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TOOLBAR BASICS

1. RIGHT HAND PANEL

COLOR, SWATCHES, STYLE

The Color palette displays the current foreground and background colours
and CMYK values for these colours. You can use the sliders to change the
foreground and background colours in different colour modes. You can also
choose a colour from the spectrum of colours displayed in the colour ramp
at the bottom of the palette.

In the Swatches palette you can choose a foreground or background
colour or add a customized colour to the library.

The Styles palette allows you to view, select, and apply preset layer styles. By default, a preset style
replaces the current layer style. You can use the styles in the palette or add your own using the

Create New Style icon.

LAYERS

Layers let you organize your work into distinct levels that can be edited
and viewed as individual units. Creating multiple layers lets you easily
control how your work is printed, displayed, and edited.

LAYERS | CHANNELS | PATHS

=] opacity: [ 100%s [
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Locks [ v ++ @ Fill: [ 1003 [» |

COLOR BOXES AND MODES

Color Boxes

nY

The foreground color appears in the upper color selection box and represents a color
that is currently active. The background color appears in the lowar box and represents an
inactive color.

To change the foreground color, click the upper color selection box in the toolbox.

To change the background color, click the lower color selection box in the toolbox.

To reverse the foreground and background colors, click the Switch Colors icon
(the arrow) in the toolbox.

To restore the default foreground and background colors, click the Default Colors icon
(the little black and white boxes) in the toolbox.

MOTE: If you are using the Gradient Tool, the currently selected foreground and back-
ground colors will be the default colors of the gradient.
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2. LEFT HAND PANEL
This area offers a vast selection of tools that you should investigate.

Some tools in the toolhar have additional “hidden” tools.
These tools have small black triangles in the right-hand corner and can he
selected by clicking and holding down the mouse button for a moment.

Magnetic Lasso Selects an object by drawing a border that snaps to the edges of the defined area of the
object.

|D-,i, SELECTION TOOLS
£l : r g ;
L4, Marquee Selects an object by drawing a rectangle or an ellipse around it.
P‘ =1 Click the tool button, choose a rectangular or an elliptical marquee. Drag the marquee
\ t=d, over the area of the image you wish to select.
ﬁ‘ Move Used to select and move objects on the page.
3 Click the tool button, then click on any object on the page you wish to move.
i g
4
5594 Lasso Belects an object by drawing a freehand border around it.
/. ‘;— p) Click the tool button, drag to draw a freehand border around the are of the image you
& 4 wish to select.
'l
.ﬁf Polygonal SBelects an object by drawing a straight-edge border around it.
& Lasso
59 - Click the tool button, click on the starting peint on the image, drag to draw a slraight-edge
4 W] border, click and drag again to select the are of the image you wish to select. Double-
& —— click to finish.
4
A
4

I w Click on the starting point on the image, drag around the are of the image. The tool will
make fastening points at the edges. To finish selecting, drag the border to the starting
point and click precisely in the point.

¥ - T

Magic Wand  Selects all objects in a document with the same or similar fill color, stroke weight, stroke
color, opacity, or blending mode. By specifying the color range, or tolerance, you can

Q)) - ‘;f\ ] control what the Magic Wand tool selects.
, "

I )
L))

g Click the tool button, then click on the area of the image you wish to select.
my Crop Tool .
}‘ Selects and cuts parts of an image.
12[_ Click the tool button, then click and drag the tool over the part of the image that you want
m Y 4 1o keep. Resize the selected area dragging the squares at the sides and corners. Click
= the RETURN key when your crop box is sized correctly.
Slice Tool Used to cut images into slices, which can be exported to a web page.

O x
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ALTERATION TOOLS

Healing Brush  Corrects small blemishes in scanned photos.

Select the tool, hold down the ALT key and left-click on the base color you need to heal.
y) y Then left-click over the blemish.

Brush Tool Draws lines of different thicknesses and colors.

/. Select the tool. Then click on the selected area, drag to draw lines. Use the Options bar
to change the Brush, Mode, Opacity, and Flow.

Clone Stamp  Takes a sample of an image and applies over another image, or a part of the

same image.
2 Select the tool. Hold down the ALT key and left-click on a certain point of the document
by, where you want to start your copy point. Then, put your mouse over whatever part of the

new document you want the picture to go to. Hold down the left mouse button and drag
the mouse across the page to copy the picture.

Art History Brush  Paints over an image using the source data from a specified history state or snapshot.

b

4

Select the tool, specify the Brush, Blending Mode, Opacity, Style, Area, and Tolerance.

Erase Tool Removes part of an exisling path or stroke. You can use the Erase tool on paths, but not
on text.
Select the tool, click on the part of the image you wish to erase. Drag to erase pixels.

4

Paint Bucket Tool Fills and entire area with a specific color of your choice.

Select the tool. Choose a foreground color in the Color Box. Select an area you wish to

W apply the color to. Click the tool button, then click on the selected area.
Gradient Tool Applies a gradient fill to a selected part of the image or to an entire layer.
Select an area you wish to apply gradient to, click the tool button, choose a fill in the Op-
Jﬁl tions bar, click on the starting point, hold the mouse down and drag to the end point.

Blur Tool Blurs the sharp edges of an image.

' Select an area where you wish to apply the tool. Click the tool button, choose the Brush,
v, Mode, and Strength. Drag the brush along the edges.
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DRAWING AND SELECTION TOOLS

Direct Selects paths and path segments.
Selection Tool

)

Type Tool Types text on a page. Every time you click the Type Tool on a new portion of the page a
new layer will be created.

Select the tool, click anywhere on the path.

T. Select the tool, click on the page and begin to type. You can specify the font and size in
the Options bar. You can also resize and transform the text box by dragging the squares
at the sides and corners. Use the Move Tool to move the text on the page.

Pen Tool Draws smooth-edged paths.
‘9 Select the tool, click on the page, drag to draw a path. Click and drag the anchor points to
il modify the path.

Rectangle Tool Draws a rectangle shape. Other shapes that are hidden in this tool are: Rounded Rect-
angle Tool, Ellipse Tool, Polygon Tool, Line Tool, and Custom Shape Tool.

F
u Select the tool, click and drag on the page to draw a shape. The shape will be automati-
cally filled with the current foreground color.

ASSISTING TOQLS

Eyedropper Tool  Takes color samples from colors on the page and displays Tool them in the Color Boxes.

} Select the tool, click on the color in the image you wish to sample. The Color Box will
. display this color.
Hand Tool Allows you to move around within the image.
6{"? Select the tool, click on the spot on the page, hold the mouse button down, drag to move
4 in the area.
Magnifying Magnifies or reduces the display of any area in your image Glass Tool window.
Q Select the tool, choose Zoom In or Zoom Out in the Options bar, click on the area of the

image you wish to magnify or reduce.

Rotate View Tool Rotates the canvas

@ Select this tool and click and drag outside of the canvas and the canvas will turn. Hold
Shift to make sure that the canvas will snap to certain degree points.
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3. ADDING IMAGES

Following the steps below, you can add each new image as a separate layer. This process allows you
to manipulate each image individually. When all of your images are assembled in the final image,
you can resize or move the layers (the added images) so that they are in the desired position.

If the Layers palette does not appear, choose Window > Layers.

Choose File > Open, and select the first image to be added to your CD cover. You now have the CD
cover and your image open at the same time.

) X | alienlandscape.jpg @ 66.7% (image 1, RGB/8#) * x H

r=1

1
Lemd
4

Using tﬁe Marquee Tool select the area of the image you wish to use, then click Edit > Copy.

1

Click CD Cover (to make it the active window), then Edit >Paste.

LAYERS | CHANNELS Lo ~=
INormai El Opacity: | 10096 I 3 I
Lock: [ & + @ Fih

Your image will be added on a new layer.

Double-click the words Layer 1 in the Layers palette,

and rename Layer 1 so that you can keep track of your layers.

Close the image 1 window so that only the CD cover is open.

Your Layers palette now contains a Background layer and the new layer that you renamed.

LAYERS | CHANNELS

Repeat these steps to add other images to your CD cover.

|100%|’
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| LA Songs from the Universe
4. TO RESIZE, REPOSITION, AND ROTATE THE IMAGES OR LAYERS ==
[® |[ZH aient
In the Layers Palette, click once on the layer that you want to adjust. P
@ . Bickground a i

Choose Edit > Free Transform (Photoshop) or
Image > Transform > Free Transform (Photoshop Elements).

Note: Before you transform your layer, make sure the correct layer is targeted in the Layers palette.

Notice the bounding box around the edges of the image and the anchor points on all four corners
and sides (eight total).

-- Resize the image by dragging the anchor points.
-- Reposition the image by clicking inside the bounding box and dragging.

-- Rotate the image by positioning your cursor just outside the bounding box, clicking, and dragging.
You can rotate the image when your cursor changes to a curved double-headed arrow.
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In the option bar at the top of the screen, either click the check box to accept the transformation or

click the circle with the slash through it to cancel the transformation.
Repeat these steps to resize, reposition, and rotate each of the other layers in the image.
To rearrange the stacking order of the layers:

To change stacking order of the layers or the way the layers overlap, drag any layer in the Layers
palette above or below another layer.

5. ADDING TEXT Investigate Warp Text %
[T]]] | o S i | afew o akee | £[E 2 I-’Ti 8| o v|

2 ol il

If you are using more than a couple of words select the Toggle the Character and Paragrapbpﬁnel
s
s
and enter your text as a paragraph. e
e

s
Click the check box to accept the text or click the circle with the slash through it to cancel.

6. SAVING YOUR FILE SIS
While you are working on your CD cover always SAVE the s

image in the default Photoshop (.PSD) file format.

This retains the maximum file information, including all your a .

layers, though the file size is large and not compatible with i e
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When you have finished your CD cover SAVE AS and select

JPEG (JPG) in file format.  This is a compressed file format and, while some quality is lost, the file
size is reduced making it suitable for use on web pages. JPEG is best for photographic images or
images with gradients.

Also save a copy of your ORIGINAL (.PSD) work in a GIF file format. This is done using the option
File > Save for Web & Devices. GIF is a compressed file format suitable for web images that have

areas of flat colour or text eg. logos and diagrams.




